All-in-One: Cannot view some candidate projects
Incident Report for Ashby
Resolved
We have now fixed this and will continue to monitor
Posted Nov 13, 2024 - 14:51 UTC
Identified
We have identified an issue preventing viewing some candidate projects and are working on a fix
Posted Nov 13, 2024 - 14:23 UTC
This incident affected: Ashby Products (Recruiting).