All-in-One & Analytics - Candidate Profile Errors
Incident Report for Ashby
Postmortem

For at most 30 minutes yesterday (June 20), candidate profiles were inaccessible in Ashby. While we quickly resolved the issue once we became aware of it, it simply shouldn't have happened - viewing candidate profiles is an important part of every team's recruiting process.

Why did this happen, and what have we put in place to prevent it from happening in the future?

Ashby has powerful features that let you analyze large amounts of data. We put safeguards in our app to prevent malicious actors from using that power to request unreasonably resource-intensive data from our servers to overload them. Yesterday, we shipped a change to the candidate profile that inadvertently triggered one of those safeguards for normal usage of Ashby.

Once we became aware of the issue, we immediately updated our status page, and our team was able to identify and ship a fix within 15 minutes. To prevent this from happening again, we added additional monitoring and automated checks to block code from being deployed that could inadvertently trigger this safeguard. These additional changes were deployed within 8 hours of the incident.

Please let us know if you have any questions or concerns.

Abhik Pramanik
Co-Founder and VP of Engineering

Posted Jun 22, 2023 - 00:43 UTC

Resolved
The issue has been resolved, and we'll follow up with customers with a post-mortem.
Posted Jun 20, 2023 - 20:05 UTC
Monitoring
We have deployed a fix. Affected customers will need to refresh Ashby in their browser.
Posted Jun 20, 2023 - 17:10 UTC
Identified
We've identified an issue that's causing candidate profiles to sometimes error and are working on a fix.
Posted Jun 20, 2023 - 17:00 UTC
This incident affected: Ashby Products (Recruiting).