Degraded application performance

Incident Report for Ashby

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 21:37 UTC

Update

We have increased our system capacity. We are monitoring to ensure the app is performing normally, and continue to investigate the root cause.
Posted Oct 21, 2025 - 18:49 UTC

Investigating

We are seeing degraded performance across the app. We're working to increase capacity while determining the root cause.
Posted Oct 21, 2025 - 18:30 UTC
This incident affected: Ashby APIs (Ashby API, Reports API, Job Post API) and Ashby Products (Recruiting, Analytics, Hosted Job Boards, Scheduling, Chrome Extension, Mobile).