Some Resumes Slow to Upload

Incident Report for Ashby

Resolved

The issue has been resolved.
Posted Apr 01, 2026 - 00:13 UTC

Monitoring

We've implemented a fix. New resume uploads should no longer be slow, and existing uploads in progress should complete within the next hour. We are monitoring and will post an update in 30m.
Posted Mar 31, 2026 - 22:53 UTC

Identified

We've identified an issue that's causing some resumes to upload slowly.
Posted Mar 31, 2026 - 22:43 UTC
This incident affected: Ashby Products (Recruiting).