All-In-One - E-Signatures Unavailable

Incident Report for Ashby

Resolved

Dropbox Sign has resolved their downtime, and we've verified e-signature works in Ashby.
Posted Jul 02, 2025 - 20:12 UTC

Update

Dropbox Sign is currently experiencing downtime. You may have issues sending e-signature requests until this is resolved.
Posted Jul 02, 2025 - 19:08 UTC

Identified

Dropbox Sign is currently experiencing downtime. You may have issues sending e-signature requests until this is resolved.
Posted Jul 02, 2025 - 19:00 UTC
This incident affected: Third-Party Integrations (Dropbox Sign).