Lever is currently experiencing issues leading to network timeouts and internal server errors when calling their APIs. Lever ATS sync operations may fail.
Posted Sep 06, 2025 - 01:38 UTC
Identified
We have identified an issue causing network timeouts when performing ATS sync operations from Lever.
Posted Sep 06, 2025 - 01:27 UTC
This incident affected: Ashby APIs (Ashby API, Reports API, Job Post API), Ashby Products (Recruiting, Analytics, Hosted Job Boards, Scheduling, Chrome Extension, Mobile), and Third-Party Integrations (ATS Sync).