We are seeing some signs of recovery but are monitoring the situation.
Posted Jul 18, 2025 - 15:41 UTC
Identified
We have identified an issue where Google APIs are slow to respond. This may cause intermittent slowness in Ashby pages as well as affect authentication, scheduling, and integrations admin performance.
Posted Jul 18, 2025 - 15:33 UTC
This incident affected: Authentication Services (Google), Ashby Products (Recruiting, Scheduling), and Third-Party Integrations (Google Gmail, Google Calendar, Google Meet).