Job configuration pages are failing to load

Incident Report for Ashby

Resolved

This incident has been resolved.
Posted May 12, 2025 - 17:24 UTC

Monitoring

The fix has been deployed. We recommend refreshing your browser. We're monitoring rollout of the fix.
Posted May 12, 2025 - 17:23 UTC

Identified

We have an identified an issue viewing job details pages within Ashby, such as when configuring or editing a job. We're deploying a fix.
Posted May 12, 2025 - 17:11 UTC
This incident affected: Ashby Products (Recruiting).