Application Submission Failures

Incident Report for Ashby

Resolved

This incident has been resolved.
Posted Jun 14, 2024 - 07:41 UTC

Monitoring

Failures have stopped, and we are monitoring the situation
Posted Jun 14, 2024 - 07:34 UTC

Investigating

We are experiencing intermittent application submission failures
Posted Jun 14, 2024 - 07:29 UTC
This incident affected: Ashby Products (Hosted Job Boards).