Unable to Manually Send Email

Incident Report for Ashby

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 23:08 UTC

Monitoring

Rollback is complete and we are monitoring to confirm resolution.
Posted Oct 29, 2025 - 22:57 UTC

Identified

The button for manually sending emails from the email editor is currently not working. Automated emails are sending normally. We are rolling back and expect resolution within 30 minutes.
Posted Oct 29, 2025 - 22:45 UTC
This incident affected: Ashby Products (Recruiting).