All-in-One: Microsoft Outage Causing Delays in M365 Email and Calendar Sync

Incident Report for Ashby

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 13:16 UTC

Monitoring

We are seeing improved performance and will continue to monitor.
Posted Jan 23, 2026 - 05:10 UTC

Identified

We have identified an issue with the upstream provider that is causing delays in syncing information.
Posted Jan 22, 2026 - 22:00 UTC
This incident affected: Third-Party Integrations (Microsoft 365).