Delays in Google Job Post Indexing

Incident Report for Ashby

Resolved

This incident has been resolved.
Posted Oct 25, 2025 - 07:08 UTC

Monitoring

We identified and fixed an issue that used up most of our daily quota for requests to Google to force re-indexing of jobs pages. We expect delays in updates to Google's indexing of Ashby jobs pages starting at 8:20pm UTC, until the quota resets at 7am UTC.
Posted Oct 24, 2025 - 20:14 UTC