Dashboard Email Delivery Delays

Incident Report for Ashby

Resolved

Scheduled dashboards are working normally again.
Posted Oct 17, 2025 - 11:46 UTC

Identified

We've identified an issue impact on-time delivery of scheduled dashboards. We're rolling out a fix
Posted Oct 17, 2025 - 11:08 UTC
This incident affected: Ashby Products (Recruiting, Analytics).