Job pages not working in Safari

Incident Report for Ashby

Monitoring

We have implemented a fix and are monitoring. Affected candidates or any user will need to refresh any links from jobs.ashbyhq.com or you.ashbyhq.com.
Posted Jun 15, 2026 - 17:30 UTC

Update

We've identified that this issue affects any job page (embedded or not) in Safari.
Posted Jun 15, 2026 - 17:12 UTC

Identified

We've identified an issue that's causing embedded job pages to not load in Safari
Posted Jun 15, 2026 - 16:59 UTC
This incident affects: Ashby Products (Hosted Job Boards).