Elevated error rate on job board API

Incident Report for Ashby

Identified

We have identified the issue and are working on a fix.
Posted May 29, 2026 - 15:11 UTC

Investigating

We are investigating intermittent elevated error rates on the job board API.
Posted May 29, 2026 - 13:41 UTC
This incident affects: Ashby APIs (Job Post API).