Elevated Ashby API Latency

Incident Report for Ashby

Identified

We have mitigated the issue, and response times have returned to normal.

We will continue to work towards full resolution.
Posted Jul 27, 2026 - 15:12 UTC

Investigating

We are experiencing elevated latency on the Ashby API available at api.ashbyhq.com, requests may take longer to be processed or time out altogether.

The Engineering team is investigating the issue.
Posted Jul 27, 2026 - 14:56 UTC
This incident affects: Ashby APIs (Ashby API).