All-in-One: Errors When Scheduling via Direct Booking Links
Incident Report for Ashby
Postmortem

Mar 18, from 1:22PM PDT (20:22 UTC) to 3:20PM PDT (22:20 UTC), when a candidate visited a Direct Booking Link, selected a time, and clicked “Book,” Ashby presented the candidate with an error that the time could not be booked.

Why did this happen?

Our infrastructure runs snapshots of code built for specific computer architectures we provision in our servers on Amazon Web Services. Last week, we inadvertently changed the targeted computer architecture of our direct booking code snapshots to ones incompatible with our servers. Since we keep backups of snapshots, direct booking continued to work until the old snapshot expired today. The expiration caused our infrastructure to use the newer incompatible snapshots and fail.

How did we resolve the situation?

Our on-call engineer identified the issue internally within 30 minutes, updated status.ashbyhq.com immediately, and resolved the issue approximately 2 hours later.

As part of remediation, we contacted affected candidates and customers directly.

What have we put in place to prevent it from happening in the future?

That day, we added monitoring to detect this specific issue immediately (versus minutes later).

We also performed a post-mortem and determined that the root cause was the lack of developer tooling and safeguards on some of our infrastructure. We have started adding the necessary hardening features to prevent this situation from occurring again.

Posted Mar 19, 2024 - 15:01 UTC

Resolved
We are considering the incident resolved.
Posted Mar 18, 2024 - 23:06 UTC
Monitoring
We have resolved the infrastructure issue and are monitoring.
Posted Mar 18, 2024 - 22:28 UTC
Identified
We've identified an infrastructure issue and are working on a fix.
Posted Mar 18, 2024 - 21:43 UTC
Investigating
We are investigating an issue where direct booking links error when candidates select a time.
Posted Mar 18, 2024 - 20:59 UTC
This incident affected: Ashby Products (Scheduling).