All-in-One - Delayed or Incorrect Status for Some E-Signatures and Offer Letters
Incident Report for Ashby
Resolved
This incident has been resolved.
Posted Sep 25, 2023 - 20:13 UTC
Monitoring
A fix has been implemented, and updates from Dropbox Sign are being processed normally. We are working to fix existing signature requests to show the correct most recent status.
Posted Sep 25, 2023 - 20:09 UTC
Identified
Some e-signatures and offer letters in Ashby may not show the most recent status (e.g., sent, viewed, signed) due to issues with our vendor, Dropbox Sign. We are investigating a workaround and working with Dropbox Sign to resolve the issue.

E-signatures and offers are still operational but, for instance, may show unsigned in Ashby when the offer or document has been signed. A byproduct is some additional features like reminders may error because they are not relevant to the current status of the document.
Posted Sep 25, 2023 - 17:57 UTC
This incident affected: Third-Party Integrations (Dropbox Sign).