All-in-One: E-Signature Signer Order Issues
Incident Report for Ashby
Resolved
Dropbox Sign identified the bug and has resolved the issue with our integration.
Posted Nov 21, 2023 - 01:20 UTC
Identified
Signature requests that have a signer order may get sent in reverse order due to an issue with our downstream e-signature provider, Dropbox Sign.

The email Dropbox Sign sends you after sending the e-signature request has the order it will be sent in, which may or may not match what was set in Ashby. Please verify the order matches what you expect, until we reach a resolution.
Posted Nov 16, 2023 - 19:59 UTC
This incident affected: Third-Party Integrations (Dropbox Sign).