Degraded performance in NYC region due to issues with upstream provider

Incident Report for Ashby

Resolved

Cloudflare's scheduled maintenance is finished, and we're no longer seeing any service degradation.
Posted Dec 03, 2025 - 19:03 UTC

Identified

The issue has been identified
Posted Dec 03, 2025 - 15:58 UTC
This incident affected: Ashby Products (Recruiting, Analytics, Hosted Job Boards, Scheduling, Chrome Extension, Mobile, AI Notetaker).